• OADINC@feddit.nl
    ·
    edit-2
    10 months ago

    This is the only way;

    if (condition) {
        code
    }
    

    Not

    if (condition)
    {
        code
    }
    

    Also because of my dyslexia I prefer variable & function names like this; 'File_Acces' I find it easier to read than 'fileAcces'

    • greywolf0x1@lemmy.ml
      ·
      edit-2
      10 months ago

      I've only seen the second type in C#, to be fair it makes code neater but i'm glad I left it for Java.

      • Evilsandwichman [none/use name]
        ·
        10 months ago

        I'm not a programmer (I tried learning programming and unity but got lazy so....) but when I learned about if-then statements, the second one seemed like the way it's supposed to be; I mean it looks so clean and simple. Do actual programmers prefer the first method?

    • AItoothbrush@lemmy.zip
      ·
      10 months ago

      It depends for me. If the condition is some goofy ahh multiline syntax hell i like to use the second option.

    • alcoholicorn [comrade/them, doe/deer]
      ·
      edit-2
      10 months ago

      I use all 3.

      If it's very short and there's 2 or more in a row, I'll put it all in one line.

      If there's a bunch of nested if statements, I'll use the second.

      If neither of those conditons, I'll use the first.